Gowin_EMPU_M1 Quick Design
Reference Manual

IPUG534-1.6E, 06/12/2020
<table>
<thead>
<tr>
<th>Date</th>
<th>Version Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>02/19/2019</td>
<td>1.0E</td>
<td>Initial version published.</td>
</tr>
</tbody>
</table>
| 07/18/2019 | 1.1E           | - MCU hardware design and software programming design support extended peripherals: CAN, Ethernet, SPI-Flash, RTC, DualTimer, TRNG, I2C, SPI, SD-Card;  
|            |                | - MCU supports off-chip SPI-Flash downloading and startup.                                                                                  |
| 08/18/2019 | 1.2E           | - MCU hardware design and software programming design support extended peripheral DDR3;                                                       
|            |                | - Fixed known issues of Size and IDE.                                                                                                         |
| 09/27/2019 | 1.3E           | - MCU hardware design and software programming design support read, write and erase of SPI-Flash;                                            
|            |                | - MCU software programming design supports a continuous multi-byte read and write of I2C;                                                    
|            |                | - Fixed known issues of address mapping of AHB2 and APB2 extended interface in MCU software programming design;                              
|            |                | - Fixed known issues of continuous read and write of DDR3 Memory in MCU software programming design.                                         |
| 12/06/2019 | 1.4E           | - MCU hardware design and software programming design supports PSRAM;                                                                       
|            |                | - Updated MCU compiling software GMD V1.0;                                                                                            |
|            |                | - Updated RTOS reference design;                                                                                                           |
|            |                | - Hardware and software reference design of AHB2 and APB2 extension bus interface added;                                                     |
| 03/04/2020 | 1.5E           | Updated the version of software.                                                                                                           |
| 06/12/2020 | 1.6E           | - MCU supports for external instruction memory;                                                                                              
|            |                | - MCU supports for external data memory;                                                                                                     
|            |                | - Extension of 6 AHB bus interfaces;                                                                                                |
|            |                | - Extension of 16 APB bus interfaces;                                                                                                        |
|            |                | - GPIO supports multiple interface types;                                                                                                   
|            |                | - i²C supports multiple interface types.                                                                                                    |
Contents

Contents ............................................................................................................... i
List of Figures ..................................................................................................... ii
List of Tables ...................................................................................................... iii
1 Reference Design............................................................................................ 1
  1.1 Software Reference Design ................................................................. 1
  1.2 Hardware Reference Design ................................................................. 1
  1.2.1 Cortex-M1 ......................................................................................... 1
  1.2.2 AHB-Lite ......................................................................................... 2
2 Software Programming Design ...................................................................... 3
  2.1 Software Environment ............................................................................ 3
  2.2 Import Software Reference Design ..................................................... 3
  2.3 ROM Configuration ................................................................................ 3
  2.4 Compile .................................................................................................. 4
  2.5 Download .............................................................................................. 5
  2.6 Reference Manual .................................................................................. 6
3 Hardware Design............................................................................................. 7
  3.1 Hardware Environment .......................................................................... 7
  3.2 Software Environment .......................................................................... 7
  3.3 Import Hardware Reference Design ................................................... 7
  3.4 Synthesize ............................................................................................ 8
  3.5 Place & Route ....................................................................................... 8
  3.6 Download ............................................................................................ 9
  3.7 Reference Manual ................................................................................. 10
4 Debug............................................................................................................ 11
  4.1 Hardware Debugging Method ............................................................. 11
  4.2 Software Debugging Method .............................................................. 11
  4.2.1 Emulator Debugging ................................................................. 11
  4.2.2 Serial Debugging .......................................................................... 11
  4.3 Reference Manual ................................................................................. 11
List of Figures

Figure 2-1 Import Software Reference Design .................................................................3
Figure 2-2 ROM Start Address and Size Configuration ..................................................4
Figure 2-3 Compiling ........................................................................................................5
Figure 2-4 Device configuration ......................................................................................6
Figure 3-2 Synthesis Reference Design ..........................................................................8
Figure 3-3 Place & Route ................................................................................................9
Figure 3-4 Device configuration ....................................................................................10
List of Tables

Table 1-1 Cortex-M1 Configuration of the Reference Design ..........................................................1
Table 1-2 AHB-Lite Configuration of the Reference Design .............................................................2
Table 3-1 Hardware Reference Design Examples ........................................................................8
1 Reference Design

1.1 Software Reference Design

Gowin_EMPU_M1 provides software reference designs with ARM Keil MDK (V5.24 and above) and GNU MCU Designer (V1.1 and above) software environment. Get following reference designs by the link: http://cdn.gowinsemi.com.cn/Gowin_EMPU_M1.zip

- Gowin_EMPU_M1\ref_design\MCU_RefDesign\Keil_RefDesign
- Gowin_EMPU_M1\ref_design\MCU_RefDesign\GMD_RefDesign

1.2 Hardware Reference Design

Gowin_EMPU_M1 provides hardware reference design. Get the reference design by the link: http://cdn.gowinsemi.com.cn/Gowin_EMPU_M1.zip

- Gowin_EMPU_M1\ref_design\FPGA_RefDesign\Debug_RefDesign
- Gowin_EMPU_M1\ref_design\FPGA_RefDesign\NoDebug_RefDesign

Taking development board reference design of DK-START-GW2A18 V2.0 in SDK for an instance, the reference design includes two parts:

- Cortex-M1 core
- AHB-Lite interface, extension AHB, and APB peripheral interface

1.2.1 Cortex-M1

The configured function modes of Cortex-M1 core are shown in Table 1-1.

<table>
<thead>
<tr>
<th>Function Mode</th>
<th>Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of external interrupts</td>
<td>32</td>
</tr>
<tr>
<td>Extended operating system</td>
<td>Supported</td>
</tr>
<tr>
<td>Data storage format</td>
<td>Little-endian format</td>
</tr>
<tr>
<td>MULT</td>
<td>Standard mode</td>
</tr>
<tr>
<td>Debugger</td>
<td>Integrated mode, four break points and two observation points</td>
</tr>
</tbody>
</table>
Function Mode | Configuration
--- | ---
 | Debugger disabled

Debug interface | Support JTAG and Serial Wire
ITCM Select | Internal Instruction Memory
ITCM size | 32KB by default
ITCM Initialization value | Enable
ITCM Initialization path | 32KB Bootload
DTCM Select | Internal Data Memory
DTCM Size | 32KB

### 1.2.2 AHB-Lite

The configured peripheral interfaces of AHB-Lite are shown in Table 1-2.

<table>
<thead>
<tr>
<th>Peripheral Interface</th>
<th>Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>UART0</td>
<td>Supported</td>
</tr>
<tr>
<td>UART1</td>
<td>Supported</td>
</tr>
<tr>
<td>GPIO</td>
<td>Supported</td>
</tr>
<tr>
<td>Timer0</td>
<td>Supported</td>
</tr>
<tr>
<td>Timer1</td>
<td>Supported</td>
</tr>
<tr>
<td>WatchDog</td>
<td>Supported</td>
</tr>
<tr>
<td>Real-time Clock</td>
<td>Supported</td>
</tr>
<tr>
<td>True Random Number Generator</td>
<td>Supported</td>
</tr>
<tr>
<td>Dual Timer</td>
<td>Supported</td>
</tr>
<tr>
<td>Internal integrated circuit, I2C</td>
<td>Supported</td>
</tr>
<tr>
<td>SPI</td>
<td>Supported</td>
</tr>
<tr>
<td>SD-Card</td>
<td>Supported</td>
</tr>
<tr>
<td>Ethernet</td>
<td>Supported</td>
</tr>
<tr>
<td>SPI-Flash</td>
<td>Supported</td>
</tr>
<tr>
<td>APB Master [1]</td>
<td>Supported</td>
</tr>
<tr>
<td>AHB Master [1]</td>
<td>Supported</td>
</tr>
</tbody>
</table>
2 Software Programming Design

2.1 Software Environment

- ARM Keil MDK (V5.24 and above)
- GOWIN MCU Designer (V1.1 and above)

2.2 Import Software Reference Design

Double click to open ARM Keil MDK, select "Project > Open Project..." to import the software reference design, as shown in Figure 2-1.

Figure 2-1 Import Software Reference Design

2.3 ROM Configuration

Take development board reference design in of DK-START-GW2A18 V2.0 SDK for an instance, you can use off-chip SPI-Flash download method, set the ROM start address as "0x400" and the ROM Size as
"0x7C00", as shown in Figure 2-2.

**Figure 2-2 ROM Start Address and Size Configuration**

![Options for Target 'boot_led' window](image)

### 2.4 Compile

Click the "Compile" button to compile the reference design and generate software design BIN file, as shown in Figure 2-3.
2.5 Download

Take development board reference design of DK-START-GW2A18 V2.0 in SDK for an instance.

Run the download tool “Programmer” in the Gowin Software or in the software installation path. Click “Edit > Configure Device” in the Programmer menu bar or Configure Device "" in the tool bar to open the "Device configuration".

- Select "External Flash Mode" from the "Access Mode" drop-down list.
- Select "exFlash C Bin Erase, Program" or "exFlash C Bin Erase, Program, Verify" from the "Operation" drop-down list.
- Import the Gowin_EMPU_M1 BIN file required in " FW/MCU Input Options > Firmware/Binary File".
- Select " External Flash Options > Device " option according to the on-board Flash chip type, such as Gowin DK-START-GW2A18 V2.0 onboard development board Winbond W25Q64BV.
- Set " External Flash Options > Start Address" as "0x400000".
- Click "Save" to finish configuring the software design BIN file download option, as shown in Figure 2-4.
After device configuration, click Program/Configure " " to complete software design BIN file downloading.

2.6 Reference Manual

For Gowin_EMPU_M1 of software design method, please refer to the following manuals:

- [IPUG533](#), Gowin_EMPU_M1 Software Programming Reference Manual
- [IPUG536](#), Gowin_EMPU_M1 IDE Software Reference Manual
- [IPUG532](#), Gowin_EMPU_M1 Download Reference Manual
- [IPUG535](#), Gowin_EMPU_M1 Serial Debugging Reference Manual
- [SUG502](#), Gowin Programmer User Guide
3 Hardware Design

3.1 Hardware Environment
DK-START-GW2A18 V2.0: GW2A-LV18PG256C8/I7

3.2 Software Environment
Gowin_V1.9.6 Beta and above

3.3 Import Hardware Reference Design
Double click to run Gowin Software. Click "File > Open..." to import hardware reference design, as shown in Figure 3-1.

Or you can open the IP Core Generator tool, reconfigure and generate Gowin_EMPU_M1 hardware design according to your requirements.

Figure 3-1 Import Hardware Reference Design

Take development board reference design of DK-START-GW2A18
V2.0 in SDK for an instance. The hardware reference design files are as shown in Table 3-1.

Table 3-1 Hardware Reference Design Examples

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>gowin_empu_m1.v</td>
<td>Gowin_EMPU_M1 hardware design</td>
</tr>
<tr>
<td>gowin_empu_m1_template.v</td>
<td>Gowin_EMPU_M1 Top Module instantiation and user application design</td>
</tr>
<tr>
<td>ahb_multiple.v</td>
<td>AHB Master [1] user peripheral extensions</td>
</tr>
<tr>
<td>apb_multiple.v</td>
<td>APB Master [1] user peripheral extensions</td>
</tr>
<tr>
<td>gowin_empu_m1.cst</td>
<td>Physical Constraints</td>
</tr>
</tbody>
</table>

3.4 Synthesize

Run the synthesis tool “Synplify Pro” or “GowinSynthesis” to generate the Netlist File, as shown in Figure 3-2.

Figure 3-1 Synthesis Reference Design

3.5 Place & Route

Run Place & Route tool to complete the Place & Route and generate the bitstream files, as shown in Figure 3-3.
3.6 Download

Take development board reference design of DK-START-GW2A18 V2.0 in SDK for an instance.

Run the download tool "Programmer" to complete the hardware design bitstream file download. Click "Edit > Configure Device" in the Programmer menu bar or Configure Device " " in the tool bar to open the "Device configuration".

- Select "External Flash Mode" from the "Access Mode" drop-down list.
- Select "exFlash C Bin Erase, Program" or "exFlash C Bin Erase, Program, Verify" from the "Operation" drop-down list.
- Import the hardware design bitstream file required in " Programming Options > File name " option.
- Select " External Flash Options > Device " option according to the on-board Flash chip type, such as Gowin DK-START-GW2A18 V2.0 onboard development board Winbond W25Q64BV.
- Set " External Flash Options > Start Address " as "0x0000000".
- Click "Save" to finish configuring the software design BIN file download option, as shown in Figure 3-4.
After device configuration, click Program/Configure "\(\text{(programmer button)}\) in the Programmer tool bar to complete hardware design bitstream files download.

### 3.7 Reference Manual

Please refer to the following manuals for Gowin_EMPU_M1 hardware design:

- **IPUG531**, Gowin_EMPU_M1 Hardware Design Reference Manual
- **SUG100**, Gowin YunYuan Software User Guide
- **SUG101**, Gowin Design Constraints Guide
- **SUG502**, Gowin Programmer User Guide
4.1 Hardware Debugging Method

Use Gowin Analyzer Oscilloscope (GAO) to debug the Gowin_EMPU_M1 FPGA hardware design.

4.2 Software Debugging Method

Gowin_EMPU_M1 supports two software programming debugging methods:

- Emulator Software On-line Debugging
- Serial Debugging

4.2.1 Emulator Debugging

**Emulator Type**

Gowin_EMPU_M1 supports the following emulator to set break points and perform single-step debugging:

- J-LINK emulator
- U-LINK emulator

**Debug interface**

Gowin_EMPU_M1 supports the following debugging interfaces:

- JTAG
- Serial Wire

4.2.2 Serial Debugging

Use serial and serial debugging assistant to print the running status.

4.3 Reference Manual

For Gowin_EMPU_M1 debugging method, refer to following manuals:

- **SUG114**, Gowin Analyzer Oscilloscope User Guide
- **IPUG536**, Gowin_EMPU_M1 IDE Software Reference Manual